Video Processing Delays
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Jan 18, 2021 - 20:45 UTC
Identified
We have identified an issue causing a delay in the availability of playback of video recordings and are currently working to resolve the issue.
Posted Jan 18, 2021 - 15:47 UTC
This incident affected: Ring Protect (Video Recording).