Ring.com Errors
Incident Report for Ring.com
Resolved
This issue has been resolved. We have clarified this issue only affected a particular quiz used to aid new Neighbors determine the quantity and type of Ring products they should purchase. No other functions or other portions of our website were affected.
Posted Nov 20, 2020 - 19:09 UTC
Update
We are continuing to investigate this issue.
Posted Nov 20, 2020 - 18:42 UTC
Investigating
We are currently investigating errors with loading the Ring.com website and store pages. We are expecting a quick resolution. Please try again later and/or keep up with this page for updates.
Posted Nov 20, 2020 - 18:42 UTC
This incident affected: Ring.com.