Customer Service Line Temporarily Unavailable

Incident Report for Ring.com

Resolved

This incident has been resolved.
Posted May 15, 2024 - 04:10 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 15, 2024 - 03:38 UTC

Identified

The issue has been identified.
Posted May 15, 2024 - 03:17 UTC

Investigating

Some neighbors may be unable to contact Ring Customer Support by telephone. We are investigating and working to resolve this issue as soon as possible.
Posted May 15, 2024 - 03:07 UTC