Video Processing Delays
Incident Report for Ring.com
Resolved
This issue was resolved and all events processed @ 1:27 AM PST
Posted 4 months ago. Jun 06, 2019 - 09:00 UTC
Update
Video processing is caught up and the issue has been resolved.
Posted 4 months ago. Jun 06, 2019 - 08:34 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Jun 05, 2019 - 21:38 UTC
Investigating
Our video processing infrastructure is running behind which is causing delays in recorded videos being available for viewing. While the video is unviewable, it's timestamp will not show up in the application's event history.

No data has been lost and the system should be caught up shortly.
Posted 4 months ago. Jun 05, 2019 - 20:05 UTC
This incident affected: Ring Protect (Video Recording).