Video Processing Delays
Incident Report for Ring.com
Resolved
This has been resolved. All videos are now processing in real time.
Posted Apr 23, 2020 - 15:03 UTC
Investigating
We have received reports of video processing delays in the Ring app and we are working to resolve as soon as possible.
Posted Apr 23, 2020 - 14:36 UTC
This incident affected: Ring Protect (Video Recording).