Login errors and the Ring app is having trouble loading
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Dec 05, 2020 - 22:57 UTC
Investigating
We are currently investigating an issue with Neighbors being unable to login to the Ring app, Neighbors already in the Ring app may experience issues with loading their dashboard, live view, or device settings.
Posted Dec 05, 2020 - 22:10 UTC
This incident affected: Ring App (iOS App, Android App, Windows App, Mac/OSX App) and Live Calls (Doorbell Dings & Motions), Video On Demand.