Incomplete Setups
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Jan 15, 2024 - 22:14 UTC
Investigating
We are currently investigating a concern that may prevent successful completion of device setups.
Posted Jan 15, 2024 - 19:42 UTC
This incident affected: Devices (Video Doorbell, Chime, Video Doorbell Pro, Stickup Cam (Original), Chime Pro, Floodlight Cam, Video Doorbell 2, Spotlight Cam (Wired & Mount), Spotlight Cam (Battery & Solar), Video Doorbell Elite, Stick Up Cam Wired, Stick Up Cam Battery, Peep Hole Cam, Indoor Cam, Stick Up Cam Plug In, Stick Up Cam Elite, Spotlight Cam Pro).