System Wide Delays and Latency
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Feb 11, 2021 - 20:23 UTC
Investigating
We are currently investigating this issue.
Posted Feb 11, 2021 - 20:07 UTC
This incident affected: Ring App (iOS App, Android App, Windows App, Mac/OSX App) and Live Calls (Doorbell Dings & Motions).