Unable to Change State of Events

Incident Report for Ring.com

Resolved

This incident has been resolved.
Posted Apr 21, 2022 - 15:27 UTC

Investigating

Some of our neighbors may encounter an issue where they are unable to delete, or otherwise change the state of their recordings. We are currently investigating this issue.
Posted Apr 21, 2022 - 14:39 UTC
This incident affected: Ring Protect (Video Recording).