Unable to verify newly created Ring accounts or update existing account password
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Sep 11, 2020 - 08:20 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 11, 2020 - 08:19 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 11, 2020 - 06:52 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 11, 2020 - 06:50 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 11, 2020 - 06:38 UTC
Update
We are continuing to investigate this issue.
Posted Sep 11, 2020 - 06:04 UTC
Investigating
We are currently investigating this issue.
Posted Sep 11, 2020 - 06:02 UTC
This incident affected: Ring.com, Account Emails and Ring App (iOS App, Android App).