Issues deleting events

Incident Report for Ring.com

Resolved

This incident has been resolved.
Posted Jun 03, 2023 - 05:20 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 03, 2023 - 03:59 UTC

Identified

We have identified that some users may experience issues when deleting events.
Posted Jun 03, 2023 - 03:59 UTC
This incident affected: Ring Protect (Video Recording).