The Ring application is currently experiencing issues, some features may not work promptly or at all.
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Apr 02, 2020 - 13:15 UTC
Monitoring
We have implemented a solution and services are beginning to restore.
Posted Apr 02, 2020 - 13:03 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 02, 2020 - 12:18 UTC
This incident affected: Ring App (iOS App, Android App, Windows App, Mac/OSX App) and Ring Protect (Video Recording), Live Calls (Doorbell Dings & Motions), Video On Demand.