Incorrect Login Dates & Client Device Information

Incident Report for Ring.com

Monitoring

We have deployed a fix for information displaying inaccurately in Control Center, due to a backend update. This fix will correct login dates shown for authorized client devices.
Posted Jul 21, 2025 - 23:15 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 18, 2025 - 18:58 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 18, 2025 - 09:07 UTC

Identified

We are aware of an issue where information is displaying inaccurately in Control Center. This is the result of a backend update, and we’re working to resolve this. We have no reason to believe this is the result of unauthorized access to customer accounts.
Posted Jul 18, 2025 - 07:20 UTC
This incident affects: Ring.com and Ring App (iOS App, Android App).