Billing Processing
Incident Report for Ring.com
Resolved
This incident has been resolved. Thank you for your patience.
Posted 5 months ago. Dec 12, 2018 - 00:50 UTC
Investigating
Our billing processing infrastructure is currently experiencing degraded performance which may prevent subscribing to our services, making changes to an existing plan, or adding a credit card to your user profile. We apologize for any inconvenience this may cause.
Posted 5 months ago. Dec 11, 2018 - 21:02 UTC
This incident affected: Ring.com.