Shop Section of Ring.com Down
Incident Report for Ring.com
Resolved
This incident has been resolved and all portions of Ring.com should now be accessible.
Posted 4 months ago. Jun 02, 2019 - 23:13 UTC
Update
We are continuing to work with one of our providers to resolve this issue. Countries outside the United States may not be able to access any portion of our website.
Posted 4 months ago. Jun 02, 2019 - 21:02 UTC
Identified
We have identified an issue causing some sections of Ring.com to display an error message "We'll be back soon. Due to an unexpected technical problem, shop.ring.com is temporarily unavailable."
Posted 4 months ago. Jun 02, 2019 - 19:15 UTC
This incident affected: Ring.com.