Customer Service Having Intermittent Connectivity (Call/Chat/Email)
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Nov 22, 2019 - 22:28 UTC
Investigating
Neighbors who may be contacting us to receive support may have trouble getting connected to our customer service agents.
Posted Nov 22, 2019 - 21:59 UTC
This incident affected: Ring.com.