ring.com/help Redirecting to Status Page
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Feb 07, 2022 - 17:43 UTC
Update
Neighbors can continue to view help articles by using the Read More buttons and browsing by device.
Posted Feb 07, 2022 - 17:30 UTC
Identified
We have identified an issue with using the search function on ring.com/help. The search will automatically redirect to status.ring.com.
Posted Feb 07, 2022 - 17:23 UTC
This incident affected: Ring.com.