Live Video is Unable to Connect
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Dec 14, 2020 - 19:05 UTC
Investigating
We are currently investigating an issue that is causing live video to fail.
Posted Dec 14, 2020 - 17:54 UTC
This incident affected: Live Calls (Doorbell Dings & Motions) and Video On Demand.