404 Error on Ring.com Pages in Multiple Regions
Incident Report for Ring.com
Resolved
The Ring.com site should be back to full functionality for all users.
Posted Jan 13, 2021 - 20:34 UTC
Investigating
When trying to access localized Ring.com websites, users may receive a "404 page not found" error message. We are working to resolve this error as quickly as possible.
Posted Jan 13, 2021 - 18:26 UTC
This incident affected: Ring.com.