Unable to View or Purchase Products on Ring.com

Incident Report for Ring.com

Resolved

This concern has been resolved.
Posted Jan 12, 2022 - 00:39 UTC

Identified

We have identified an issue with one of our providers that may cause neighbors to be unable to view, add or purchase products from Ring.com
Posted Jan 11, 2022 - 23:55 UTC
This incident affected: Ring.com.