Delay In Activating Ring Home Plan Features On New Device Setups

Incident Report for Ring.com

Resolved

This incident has been resolved
Posted Jun 12, 2025 - 21:47 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 12, 2025 - 19:27 UTC
This incident affected: Ring Protect (Video Recording).