Ring.com buttons nonfunctional
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Oct 19, 2024 - 02:54 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 19, 2024 - 00:19 UTC
Investigating
We are currently investigating issues where certain buttons are not clickable when adding items to your cart on Ring.com. In the mean time, refreshing the page usually resolves the issue.
Posted Oct 18, 2024 - 22:14 UTC
This incident affected: Ring.com.