Possible Delay in Receiving 2-Step Verification via SMS (UK)
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Jan 16, 2021 - 17:42 UTC
Identified
We have identified an issue with our 2-Step verification via SMS (UK).
Posted Jan 16, 2021 - 13:06 UTC
This incident affected: Ring App (iOS App, Android App, Windows App, Mac/OSX App).