Delay In Ring Video Recording
Incident Report for Ring.com
Resolved
Most impacted videos are available for viewing. We have identified some videos are still not available for playback and are working diligently to process them. Thank you for your patience as we resolve this matter.
Posted 8 days ago. Sep 13, 2019 - 12:05 UTC
Update
We have processed most of the videos that were delayed. Our team is still working on processing older videos that have not yet become available for playback.

We will provide an update here when all impacted videos are viewable.
Posted 8 days ago. Sep 13, 2019 - 02:30 UTC
Monitoring
Our team has implemented a partial fix that has allowed new recordings to process in real time. We are continuing to process older videos that are still delayed. We will provide an update here when all impacted videos should be available.
Posted 8 days ago. Sep 12, 2019 - 16:52 UTC
Identified
We have identified an issue causing a delay in video processing. We are working to establish a fix at this time.
Posted 8 days ago. Sep 12, 2019 - 13:06 UTC
Monitoring
A fix has been implemented and new recordings should be available within a few seconds, but events that occurred during the course of this incident may not be available yet. We're working on getting those events re-processed ASAP, and they should become available shortly.
Posted 9 days ago. Sep 12, 2019 - 06:42 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 9 days ago. Sep 12, 2019 - 01:41 UTC
Investigating
We are currently investigating a delay in recordings being available.
Posted 9 days ago. Sep 12, 2019 - 00:41 UTC
This incident affected: Ring Protect (Video Recording).