Account Authorization Email Delay
Incident Report for Ring.com
Resolved
This issue has been resolved and all new authorization emails should be working normally.
Posted 3 months ago. Jun 21, 2019 - 08:15 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Jun 21, 2019 - 04:47 UTC
Investigating
We are currently investigating an issue with delays in account authorization emails.
Posted 3 months ago. Jun 21, 2019 - 03:55 UTC
This incident affected: Ring.com.