Ring.com/Ring App Login Failure
Incident Report for Ring.com
Resolved
We have resolved the problem causing users to be unable to login to the website or Ring app or users unable to load the Ring app. We have seen all activity return to normal as of 2:35 PDT today.
Posted Jul 17, 2020 - 22:10 UTC
Monitoring
We have seen many users recovering from these login and app loading failures, but we are continuing to monitor the remaining cases to ensure resolution for everybody. We will continue to update once we have verified normal operations.
Posted Jul 17, 2020 - 21:49 UTC
Identified
We have identified an issue that is causing some neighbors to have difficulty logging into the Ring website or the Ring app. Some users may also see the error "unable to load locations" when opening the app. We appreciate your patience and understanding while we work to resolve this issue.
Posted Jul 17, 2020 - 21:34 UTC
This incident affected: Ring.com and Ring App (iOS App, Android App, Windows App, Mac/OSX App).