Auth, Password Reset, and Account Verification Emails
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Sep 17, 2019 - 01:17 UTC
Monitoring
We have identified the source of the delay and we are monitoring the queue of delayed emails that have been requested. If you are waiting for one of these emails, please monitor your email inbox for your password reset/email verification email.
Posted Sep 17, 2019 - 00:17 UTC
Investigating
We are experiencing delays in sending new account email verification emails and password reset emails. We are looking into the cause and working to resolve the delay as soon as possible.
Posted Sep 17, 2019 - 00:03 UTC
This incident affected: Ring.com.