Delays in receiving password reset emails
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Nov 03, 2022 - 23:30 UTC
Update
We are continuing to investigate this issue.
Posted Nov 03, 2022 - 23:01 UTC
Investigating
We are aware of a delay of 15+ minutes in receiving password reset emails for Ring accounts. We are currently investigating the cause of this delay.
Posted Nov 03, 2022 - 21:12 UTC
This incident affected: Ring.com and Account Emails.