Unable to Process Payments for shop.ring.com orders or Ring Protect Plans
Incident Report for Ring.com
Resolved
The issue with payments for orders or subscriptions has been resolved.
Posted May 11, 2020 - 16:50 UTC
Investigating
We are currently investigating an issue with our payment platform causing an inability to process payments for product orders on shop.ring.com or process new charges for the Ring Protect subscription plans. We are working to resolve this error and will provide updates when orders can be placed again.
Posted May 11, 2020 - 16:29 UTC
This incident affected: Ring.com.