Live Video Unavailable on the Rapid Ring App
Incident Report for Ring.com
Resolved
The Rapid Ring app has returned to the Google Play store and should be available for users in the United States of America, United Kingdom and Australia at this time.
Posted Sep 19, 2019 - 20:00 UTC
Investigating
We have identified a problem with live video feeds on the Rapid Ring App for Android users. We are currently investigating the cause.
Posted Sep 16, 2019 - 21:00 UTC
This incident affected: Video On Demand.