Unable To Reset Password
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Sep 11, 2020 - 02:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 11, 2020 - 02:28 UTC
Identified
We have identified an issue with being unable to reset passwords via "Forgot password" and a fix is being implemented. If logged in, users will still be able to reset their passwords from the account page.
Posted Sep 11, 2020 - 01:39 UTC
This incident affected: Ring.com and Ring App (iOS App, Android App, Windows App, Mac/OSX App).