Billing Processing Delays
Incident Report for Ring.com
Resolved
This incident has been resolved. All jobs have been processed.
Posted 3 months ago. Jun 11, 2019 - 20:15 UTC
Monitoring
A fix has been implemented and we are monitoring results. All jobs are being retried.
Posted 3 months ago. Jun 11, 2019 - 19:51 UTC
Identified
Our billing processing infrastructure is running behind which is causing delays to new subscriptions or changes to existing subscription plans. No data has been lost and the system should be caught up shortly.
Posted 3 months ago. Jun 11, 2019 - 19:31 UTC
This incident affected: Ring.com and Ring Protect (Video Recording).