Live Video Feed Failures
Incident Report for Ring.com
Resolved
We have identified and resolved our trouble with live video connections. All users should be able to connect to live view, push button, and motion events normally. Thank you for your patience.
Posted Nov 18, 2020 - 21:31 UTC
Update
We are continuing to investigate this issue.
Posted Nov 18, 2020 - 21:00 UTC
Update
We are continuing to investigate this issue.
Posted Nov 18, 2020 - 21:00 UTC
Investigating
We are investigating reports of failures when trying to connect to an on-demand live view events as well as doorbell button push events and motion events. You may receive delays or errors when trying to access live video feeds from your device. We are working to resolve this as soon as possible.
Posted Nov 18, 2020 - 20:55 UTC
This incident affected: Ring App (iOS App, Android App, Windows App, Mac/OSX App) and Live Calls (Doorbell Dings & Motions), Video On Demand.