Dashboard Preview Tiles Not Updating
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Jan 30, 2020 - 07:13 UTC
Investigating
We are currently investigating an issue with our app's dashboard preview tiles not updating.
Posted Jan 30, 2020 - 04:34 UTC
This incident affected: Ring App (iOS App, Android App, Windows App).