Degraded Performance
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Jul 21, 2018 - 01:43 UTC
Monitoring
A fix has been implemented, and we are monitoring the results. You may expierence your event list not being up to date. However it will update shortly as everything catches up.
Posted Jul 20, 2018 - 23:50 UTC
Investigating
We are currently experiencing degraded performance with some products and services.

We are still investigating the issue, but we have received multiple reports of delayed notifications or not receiving notifications, Live View not loading or showing a black screen, and some Ring devices not setting up.

Thank you for your patience in the meantime.
Posted Jul 20, 2018 - 23:12 UTC
This incident affected: Devices (Video Doorbell, Chime, Video Doorbell Pro, Stickup Cam (Original), Chime Pro, Floodlight Cam, Video Doorbell 2, Spotlight Cam (Wired & Mount), Spotlight Cam (Battery & Solar), Video Doorbell Elite) and Live Calls (Doorbell Dings & Motions), Video On Demand.