Merchant Provider Partial Outage
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 06, 2019 - 18:25 UTC
Monitoring
Our merchant provider has restored service levels to normal and we are monitoring for any residual failures.
Posted 4 months ago. Feb 06, 2019 - 16:29 UTC
Identified
We're experiencing a partial outage of our merchant provider services across the U.S. and Canada. They are currently working to restore service levels to normal.
Posted 4 months ago. Feb 06, 2019 - 16:18 UTC
This incident affected: Ring.com.