Billing outage
Incident Report for Ring.com
Resolved
This issue has been resolved and service levels have been returned to normal. All systems are functional.
Posted 2 months ago. Jul 10, 2019 - 17:17 UTC
Identified
We are currently experiencing difficulties with processing changes to subscriptions, new purchases through our website, and other billing related functions.
Posted 2 months ago. Jul 10, 2019 - 17:08 UTC
This incident affected: Ring.com and Ring Protect (Video Recording).