Emails to help@ring.com are unable to be received
Incident Report for Ring.com
Resolved
Emails to help@ring.com are functioning normally.
Posted 8 months ago. Dec 12, 2018 - 10:57 UTC
Investigating
We are currently working to resolve an issue that will not allow us to receive emails to help@ring.com
In the meantime, our chat and phone agents are ready to receive your inquiries. You can reach us through our website at ring.com for chat or call us. Our list of toll-free numbers can be found here: https://support.ring.com/hc/en-us/articles/213608406-Contact-Community-Support-Worldwide
Posted 8 months ago. Dec 12, 2018 - 06:29 UTC
This incident affected: Ring.com.