Elevated Processing Errors
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted 5 months ago. Dec 11, 2018 - 00:06 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Dec 10, 2018 - 23:59 UTC
Investigating
We're experiencing an elevated level of Billing processing errors that are causing problems with adding credit card information. This is also affecting adding additional Ring services and product orders. We are currently looking into the issue. This has no effect to current recording plans or device features.
Posted 5 months ago. Dec 10, 2018 - 22:34 UTC
This incident affected: Ring.com.