Email Delivery Outage
Incident Report for Ring.com
Resolved
All systems are now operational.
Posted Jul 28, 2020 - 22:14 UTC
Identified
We're currently experiencing an outage in our email delivery system which can affect the ability to receive 2-Step Verification codes, email verification emails, password reset emails, and low battery notifications.
Posted Jul 28, 2020 - 17:05 UTC
This incident affected: Ring.com and Account Emails.