Unable To Chat Into Support
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted Sep 15, 2020 - 22:15 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 15, 2020 - 21:34 UTC
Investigating
We are currently investigating an issue with being unable to chat into Ring support.
Posted Sep 15, 2020 - 21:26 UTC
This incident affected: Ring App (iOS App, Android App) and Ring.com.