Call Connectivity
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 19, 2019 - 18:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Aug 19, 2019 - 18:18 UTC
Investigating
We are currently experiencing intermittent connection issues across our neighbor support platforms. This may lead to increased hold times and/or dropped chat or support calls. Our team is working to restore service levels as quickly as possible.
Posted about 1 month ago. Aug 19, 2019 - 17:23 UTC