Video Availability Delay
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted May 16, 2020 - 14:43 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 16, 2020 - 13:26 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 16, 2020 - 13:19 UTC
Investigating
We have identified an error that is currently impacting how quickly videos are made available to view in our app and our website. We are currently working on a resolution.
Posted May 16, 2020 - 12:02 UTC
This incident affected: Ring.com, Ring Protect (Video Recording) and Ring App (iOS App, Android App, Windows App, Mac/OSX App).