Password Reset Emails Delayed
Incident Report for Ring.com
Resolved
We have resolved this issue and password reset emails should now be in your email inboxes and delivering normally.
Posted about 1 month ago. Apr 16, 2019 - 23:05 UTC
Identified
There is a small delay in sending password reset emails at this time. We are currently working to process the email queue and should be caught up shortly.
Posted about 1 month ago. Apr 16, 2019 - 21:43 UTC
This incident affected: Ring.com.