App Dashboard Loading Failure
Incident Report for Ring.com
Resolved
This issue has been resolved. All services have been restored to normal.
Posted May 20, 2020 - 17:39 UTC
Identified
Some neighbors may see their dashboard fail to load and an error message in the Ring app that says there is a "Temporary Connection Issue." We are working to resolve this issue as soon as possible. We thank you for your patience in the meantime.
Posted May 20, 2020 - 16:56 UTC
This incident affected: Ring App (iOS App, Android App, Windows App, Mac/OSX App).