Slow loading and connection errors when accessing Ring.com
Incident Report for Ring.com
Resolved
This incident has been resolved.
Posted 9 months ago. Dec 04, 2018 - 00:48 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 9 months ago. Dec 03, 2018 - 23:28 UTC
Investigating
We're experiencing an elevated level of slow connections and website errors on our Ring.com web page. We are currently looking into the issue.
Posted 9 months ago. Dec 03, 2018 - 22:44 UTC
This incident affected: Ring.com.