Activity Feed Update
Incident Report for Ring.com
Resolved
The In-App activity feed is now caught up and processing live. If you have any problems please contact us at help@ring.com
Posted Jun 11, 2017 - 00:19 UTC
Investigating
We are currently investigating an issue with new videos delayed up to 15 minutes on the In-App activity feed. Please note all videos are getting saved and live calls are working, they are just not showing up in app immediately.
Posted Jun 10, 2017 - 22:47 UTC