Account Creation
Incident Report for Ring.com
Resolved
We have resolved the issue of seeing "no internet connection" during account creation after tapping sign up in the iOS Ring app.
Posted Dec 08, 2017 - 22:49 UTC
Identified
We have identified an issue with account creation. Some neighbors will see "no internet connection" when tapping sign up in the Ring app on iOS. You can create an account using ring.com in the meantime Our developers are working diligently to get everything back up and running as soon as possible.
Posted Dec 08, 2017 - 17:52 UTC