Delayed or low quality video for East coast U.S.
Incident Report for Ring.com
Resolved
This matter has been resolved and services have been restored to expected levels.
Posted Feb 08, 2018 - 17:08 UTC
Identified
We are aware of an issue that may be causing delays in video. We appreciate your patience as we work to resolve this issue.
Posted Feb 08, 2018 - 13:37 UTC